New in version 1.2.1

May 2nd, 2013
  • Removed longly deprecated actionicons.xml [keul]
  • Modern inclusion of referencebrowserwidget [keul]
  • Restored tests on Plone 3.3 that were broken in version 1.2 [keul]
  • Removed old ununsed import step (close #1) [keul]
  • Fixed product to be Plone 4.3 compatible [keul]
  • Old (4.2 and below) link_icon.gif now included with the product [keul]

New in version 1.2.0 (January 25th, 2013)

  • Added support for plone.app.imaging [cekk]

New in version 1.1.2 (May 23rd, 2012)

  • fixed a bug on Plone 3 if plone.app.blob is not present [keul]

New in version 1.1.1 (May 19th, 2012)

  • fixed tests for Plone 4.2 compatibility [keul]
  • migrating "fake external links" now support the migration of URLs that explicitly use "resolveuid" (sometimes Plone users are really evil) [keul]

New in version 1.1.0 (February 26th, 2012)

  • added a link to the view that migrate to blob from the control panel [keul]
  • added a new Smart Link: access configuration permission for site configuration that "Site Administrator" role can handle [keul]
  • added an utility to convert "fake external" link to internal [keul]
  • aligned all Link.xml files to be Plone 4 compliant [keul]
  • In Plone 4 the related items where duplicated (if used). Now Plone 3.3 requires collective.relateditems [keul]
  • Moved URL transformation features to an ILinkNormalizerUtility [keul]
  • fixed all tests to be compatible again with Plone 3.3.6 [keul]
  • fixed bug when providing a non ASCII URL (close #8) [keul]
  • provide a count of updated links when using the administration utility (close #6) [keul]
  • provided an import step to migrate ATLink to Smart Link (close #7) [keul]
  • provided an import step to go back to ATLink from Smart Link [keul]

New in version 1.0.0 RC2 (March 25th, 2011)

  • reStructured text fixes [keul]
  • uninstall was not working under Plone 4.0 (this close #5) [keul]
  • URL utility description updated with latests features added in 1.0 version [keul]
  • fixed duplicated icon when using (or not using anymore) this product on Plone 4 (close #4). To make those additional icon disappear from Plone UI you may need a catalog update. [keul]
  • configuration icon was not displayed properly on Plone 4 [keul]
  • added the "Front-end main URL" feature (close #3) [keul]