Xtables-addons Changelog

New in version 2.2

April 1st, 2013
  • Support for Linux 3.9 was added.
  • The iptaccount tool was miscompiled on PPC, which has been fixed.

New in version 2.1 (December 27th, 2012)

  • Fixes:
  • DNETMAP: fix compile error with Linux 3.7
  • Enhancements:
  • Support for Linux 3.8

New in version 2.0 (November 15th, 2012)

  • Changes:
  • remove support for Linux 2.6.17–3.6
  • remove xt_TEE (this is available upstream since 2.6.35)
  • remove xt_CHECKSUM (this is available upstream since 2.6.36)
  • Enhancements:
  • Support for Linux 3.7
  • If you want to use Xtables-addons with kernels older than 3.7, use the addons 1.x series, which continues to be maintained for the time being.

New in version 1.47.1 (October 16th, 2012)

  • Enhancements:
  • xt_psd gained IPv6 support
  • Notes for this release:
  • Linux 3.7+ is expressly unsupported by this release.

New in version 1.45 (July 16th, 2012)

  • Fixes:
  • build: export missing functions (fixes: "WARNING 'xtnu_ipv6_find_hdr' [xt_TARPIT.ko] not found")
  • build: avoid use of unexported functions (fixes: "WARNING 'ipv6_find_hdr' [xt_TARPIT.ko] not found" in

New in version 1.42 (April 21st, 2012)

  • Fixes:
  • compat_xtables: fixed mistranslation of checkentry return values (affected kernels < 2.6.23)
  • xt_SYSRQ: fix compile error when crypto is turned off
  • Changes:
  • ipset6-genl has been dropped from the tree; the libmnl build-time dependency is thus no longer needed
  • Enhancements:
  • Support for Linux 3.3, 3.4

New in version 1.41 (January 5th, 2012)

  • Deactivate build of ipset-genl by default.
  • I think the original ipset package can now take over, given there are a handful of kernels (2.6.39 onwards) that do not need patching.
  • Support for Linux 3.2

New in version 1.40 (November 30th, 2011)

  • Fixes:
  • build: the code actually requires at least iptables 1.4.5 (would yield a compile error otherwise), make sure configure checks for it; update INSTALL
  • xt_ECHO: fix kernel warning about RTAX_HOPLIMIT being used
  • xt_ipv4options: fix an infinite loop
  • Changes:
  • xt_ECHO: now calculates UDP checksum
  • Linux kernel versions below 2.6.32 are no longer officially supported, and will not be part of compilation testing.
  • update to ipset 6.10
  • Enhancements:
  • xt_ECHO: IPv6 support

New in version 1.38 (August 22nd, 2011)

  • xt_CHECKSUM: abort build when the feature is already provided by mainline
  • xt_SYSRQ: fix UDPLITE header lookup in IPv6
  • xt_TARPIT: fix kernel warning about RTAX_HOPLIMIT being used
  • xt_TEE: abort build when the feature is already provided by mainline
  • xt_ipp2p: support UDPLITE
  • xt_pknock: support UDPLITE
  • xt_psd: restore functionality with UDP
  • xt_psd: support UDPLITE
  • update to ipset 6.8
  • support for Linux 3.1