GeoToad Changelog

New in version 3.22.0

October 31st, 2014
  • Issue 309: Use new user preferences page after 2014-10-14 site update
  • Support for some new ("dotted") data formats
  • History logging removed again
  • Minor stuff

New in version 3.20.0 (January 17th, 2014)

  • This release removes "fun factor" support and addresses an issue triggered by HTML reformatting of "printable cache details" pages.

New in version 3.19.2 (January 7th, 2014)

  • This is an interim release, before removing the "fun factor" functionality completely.
  • Also, a few quirks have been addressed.

New in version 3.19.1 (December 23rd, 2013)

  • Issues addressed:
  • Issue 198: get some data from PMO caches (but no coords)
  • Issue 271 more nuvi adjustments
  • Issue 285: no problems with ruby 2.0
  • Issue 288: cookie cleanup
  • Issue 293: avoid listing filters twice
  • Added some long options (to be abridged again)
  • "-l" ("--waypointLength") option renamed to "-w" (issue 286 related)
  • Numerous minor additions, modifications, cleanups, and bug fixes

New in version 3.19.0 (November 21st, 2013)

  • This vrsion fixes an issue caused by GroundSpeak's addition of Facebook logins (a.k.a., 20131114.1 HotFix).
  • There are packages for OS X (.dmg), Windows (using the InnoSetup installer and the Ocra gem with Ruby 1.9.3), and Debian/Ubuntu Linux (.deb), and a generic tarball. Unfortunately, there's no Ruby 2.0 installer package available yet.

New in version 3.18.1 (October 31st, 2013)

  • This version addresses a couple of minor issues affecting: date parsing; HTML entities in cache, owner, or finder names, and deprecated gpsbabel output formats.
  • The Windows installer comes with Ruby 1.9.3 pre-packaged; otherwise, Ruby 1.9.1 or higher is required.
  • Ruby 2.0 isn't officially supported yet. Please do not use pre-3.18 versions anymore.

New in version 3.17.11 (September 13th, 2013)

  • This version has grown from the convergence of the 3.16(.9) and 3.17(.10) trees, and incorporates a number of fixes to accommodate the 20130821 HotFix changes which rendered the previous versions unusable.
  • There's a "dictionary" being used now, and you may want to fill this with knowledge already on your disk before starting GeoToad again.
  • See the project wiki on GoogleCode for details.
  • Ruby 1.8 support has been removed, and Ruby 1.9 is required.

New in version 3.16.9 (July 4th, 2013)

  • Two serious bugs were fixed, one obvious and one better hidden.

New in version 3.16.8 (June 27th, 2013)

  • The version is the last stable version still supporting Ruby 1.8 (which will be phased out soon).
  • It is now possible to read found caches from a list (-E name=file), fetch a list of cache logs (-M), and save history to the local disk.
  • There were plenty of minor fixes, additions, and cleanups.