GLE Changelog

New in version 4.2.4

January 8th, 2012
  • This version adds control constructs (for-next loops, if-then-else, etc.) in graph and key blocks, semi-transparent fills and colors (RGBA), the concept of layers for graph blocks, and a new CSV data reader.

New in version 4.2.2 (January 18th, 2010)

  • New Features:
  • Windows installer can now copy settings from a previous GLE install thereby avoiding the long 'find dependencies' process.
  • Support '' style umlauts in LaTeX expressions (bug #2858424).
  • Additional command line options for GhostScript/PDFLaTeX/LaTeX/DVIPS can now be specified in the "glerc" settings file
  • GLE now expands environment variables in the tool paths specified in the "glerc" settings file.
  • Bug Fixes:
  • QGLE now no longer modifies the string argument of "write" if a text string is moved or one of its properties is changed.
  • GLE now compiles with "-Wl,--no-add-needed" and hopefully also with binutils-gold.
  • Fixed GLE crash on illegal font name.
  • Fixed GLE crash on certain scripts with error bars.
  • Fixed regression in key block in 3.5 compatibility mode.
  • Diamond markers are now also centered in 3.5 emulation mode.
  • QGLE now sets the locale such that the decimal point indicator is "." (workaround "export LC_ALL=C").
  • Fixed crash in certain bar graphs (reported by Massimo Canonico).