RPG Next Gen Editor 0.5.5

A lightweight RPG editor
RPG Next Gen Editor is a lightweight RPG editor tool solely based on the Eclipse platform. It has some basic plugins which among other things provide a tree view on the QSYS filesystem. The focus for the editor lies on small size and speed. The goal for this project is a feature complete RPG free-format editor which can be used to develop small to midsized projects for even the most advanced programming style.

The RCP Application will be developed platform independent. With the help of the Eclipse RCP Delta Pack there will be a version for each of the main operating systems.

Main features:

  • QSYS.LIB filesystem browser
  • QSYS.LIB filesystem browser filter
  • Multiple connections
  • Configurable connection library list
  • Local password encryption
  • Spooled file viewer
  • Non-default workstation customization file possible
  • Data area wizard and editor
  • Userspace wizard and viewer
  • RPGLE editor (/free-form)
  • RPGLE Syntax Highlighting
  • Editor Outline support
  • Procedures:
  • Local source history
  • Task Keywords support
  • Quick source member access
  • Source compilation submitter
  • Global compile options per compile command
  • Per source compile options
  • Custom compile options provider (Extension Point)
  • Custom Remote Explorer open action provider (Extension Point)
  • Member locking on editing
  • Source export (flat or ZIP archive file)
  • Simple RPG Abstract Syntax Tree
  • Toggle Comment (/free and fixed format)
  • Command Line view
  • Compile Result view

last updated on:
December 17th, 2010, 11:17 GMT
price:
FREE!
developed by:
Mihael Schmidt
homepage:
www.rpgnextgen.com
license type:
GPL v3 
category:
ROOT \ Text Editing&Processing \ IDEs

FREE!

In a hurry? Add it to your Download Basket!

user rating

UNRATED
0.0/5
 

0/5

Rate it!
What's New in This Release:
  • The main new feature of this release is the new RPGUnit plugin.
  • It lets you execute unit tests written with RPGUnit from the editor.
  • The result will be shown in an extra view.
  • For this to work, you need the RPGUnit package from rpgnextgen.com.
read full changelog

Add your review!

SUBMIT