JRequisite 0.0.1

JRequisite is an agile requirement management tool.
JRequisite is an agile requirement management tool, which means your requirements are defined mainly via visual tools as opposed to textual requirement tools.

Also, it is independent of the process used, so you may apply any process to your development. Despite being a requirement analysis and management tool, JRequisite tools are so general that they can be used in other areas of software development and even non-software related fields.

Requirements:

Java SE 1.4.2 or newer
Eclipse 3.2.1, with the following additions:
EMF 2.2.2, including SDO
XSD 2.2.2
GEF 3.2.2
OCL 1.0.2
Query 1.0.2
Validation 1.0.2
Transaction 1.0.3
GMF 1.0.2

How to install

JRequisite is a set of Eclipse plugins which are based on the GMF (Graphical Modeling Framework). Therefore, the installation process is very simple if you are complaint to the tool requirements.

At this time, the installation process is a bit manual, but we intend to provide an Eclipse installation/update site soon. Currently, all you have to do is to download the bundle which contains the plugins, and unpack it at your Eclipse root directory.

What's New in This Release:

This first release contains a fully functional Flowchart diagram editor that is based on the Eclipse GMF (Graphical Modeling Framework).

last updated on:
December 14th, 2006, 15:21 GMT
price:
FREE!
developed by:
Marcos Pereira
homepage:
jrequisite.sourceforge.net
license type:
GPL (GNU General Public License) 
category:
ROOT \ Programming \ Quality Assurance and Testing

FREE!

In a hurry? Add it to your Download Basket!

user rating

UNRATED
0.0/5
 

0/5

1 Screenshot
JRequisite

Add your review!

SUBMIT