WebKitGTK+

2.8.0 LGPL (GNU Lesser General Public License)    
5.0/5 1

  636 downloads

A GTK+/GNOME port of the WebKit portable web rendering engine for Linux and UNIX systems

editor's review

download

specs

changelog

WebKitGTK+ is a completely free, versatile, powerful and open source command-line software that aims to port the powerful WebKit rendering engine to the GTK+ GUI toolkit and, of course, the GNOME graphical desktop environment.

The project incorporates WebKit's full functionality through a set of GObject-based APIs (Application Programming Interfaces), and it is suitable for applications that require any type of web integration, from mature web browsers to hybrid HTML/CSS apps.

Used in Epiphany, Midori, and other powerful apps

WebKitGTK+ is successfully used in popular and powerful applications that work under the GNOME desktop environment or require the GTK+ toolkit, such as the Epiphany and Midor web browsers.

The project is very useful on both desktop and embedded systems, it supports WebKit2, and allows developers to easily build applications that rely on the web platform for increased responsiveness and security.

Uses process separation to support GTK+2 plugins on GTK+3 apps

Another interesting feature is process separation, which is used by WebKitGTK+ to seamlessly support plugins that are written in the 2.x branch of GTK+, such as Adobe Flash Player, in GTK+3 apps.

In addition, WebKitGTK+ offers full support for video and audio streams in web pages through the GStreamer WebKit backend, supports the HTML canvas element, supports WebRTC and WebAudio technologies, as well as accelerated rendering and 3D CSS.

Under the hood

Among WebKitGTK+'s runtime requirements (be aware that the list will change in time, as the project evolves), we can mention GTK+ 3.6.0 or later, gail 3.0 or later, GLib 2.36.0 or higher, libsoup 2.42.0 or later, Cairo 1.10 or higher, Pango 1.30.0 or higher, libxml or later 2.6, fontconfig 2.5 or later, FreeType2 or higher 9.0, and libsecret.

Moreover, depending on your configuration options WebKitGTK+ may also require GObject introspection 1.32.0 or higher, libxslt 1.1.7 or later, SQLite 3.0 or later, GStreamer 1.0.3 or higher, gstreamer-plugins-base 1.0.3 or later, Enchant 0.22 or later, Clutter, as well as Clutter GTK+.
read more   
WebKitGTK+ was reviewed by
5.0/5
Last updated on March 23rd, 2015

#rendering engine #WebKit GTK+ #GNOME WebKit #WebKit #GTK+ #rendering #engine

WebKitGTK+ - WebKitGTK+ is heavily used on the GNOME desktop environment

0 User reviews so far.

SUBMIT