Atli iconAtli 0.1.3

Atli is a scripting language interpreter.
Atli is a scripting language interpreter originally meant to be a quick way to develop a particular application's scripting language.

Atli can also be used to write shell-like scripts to do tasks. Atli is a weakly typed language in which variables do not need to be declared before use.

All variables are stored as strings and converted between string and number form automatically.

Atli provides interfaces to cooperate with applications, so applications can exchange data and instructions with atli through a callback function.

Installation:

atli can be compiled by gcc 3.3 and its later version. The typically steps are:

$cd $atli
$./configure
$make
$su -c 'make install'

NOTE: When run the program "atli", you may get message complain that libatlidll.so.0 can not be found. The following steps is required as root:

#cd /etc
#vi ld.so.conf
// add one line: /usr/local/lib to /etc/ld.so.conf
#ldconf

The release tar file contains the binary executable files in the fold $atli/bin/linux. I uses Fedora-2 to compile it.

What's New in This Release:

Some overflow bugs are fixed.
The keyword "load" has been added to load dynamic libraries on Windows or Linux.
This release differentiates among atli-function-call, lib-function-call, and application-function-call.
It calls the types function in lib: double function-name (double).

last updated on:
November 21st, 2005, 15:03 GMT
price:
FREE!
developed by:
linxs
license type:
GPL (GNU General Public License) 
category:
ROOT \ Programming \ Interpreters

FREE!

In a hurry? Add it to your Download Basket!

user rating 15

UNRATED
1.9/5
 

0/5

Add your review!

SUBMIT