Apache DSSI 1.0.0

Apache DSSI is a SSI extention for calling Dynamic function.
LICENSE TYPE:
The Apache License 
USER RATING:
UNRATED
  0.0/5
DEVELOPED BY:
S.J.G
HOMEPAGE:
apache_dssi.tripod.com
CATEGORY:
ROOT \ Internet \ HTTP (WWW)
Apache DSSI is a SSI extention for calling Dynamic function.

By using this extentions to mod_include, you can make your own function for SSI (Server Side Includes) and you can call your function with SSI directives. This solution is based on mod_so and mod_include. By using DSSI, you can integrate your CGI easily and make your CGI faster than any other CGI accelerator.

Installation:

Download and compile Apache 1.3.X
Simply download dssi_1.0.0.tar.gz
Unzip and untar.
Replace apache_1.3.X/src/modules/standard/mod_include.c with this mod_include.c
Configure.
./configure --enable-module=include
If your binary type is ELF,
LDFLAGS="-export-dynamic" ./configure --enable-module=include
Compile and install apache.

Enabling DSSI

By using LoadDSSI directive, you can load your dynamic functions. Later one override earlier ones. It means, you can only call functions of the last one with DSSI directive.

AddType text/html .shtml
AddHandler server-parsed .shtml
LoadDSSI libexec/dssi_util.so
LoadDSSI libexec/dssi.so

Last updated on April 4th, 2006

requirements

#SSI extention #calling Dynamic function #Apache module #Apache #DSSI #SSI #extention

  Add it to your Download Basket!

 Add it to your Watch List!

0/5

Rate it!
send us
an update

Add your review!

SUBMIT