Be The Wumpus iconBe The Wumpus 0.05

Be The Wumpus is a game with no graphics and no text, only audio.
Be The Wumpus is a RPG (role-playing) game with no graphics and no text, only audio. You are a wumpus, a blind, cave-dwelling creature who subsists on meals of unlucky cave wanderers.

Back in the 70's, you may have been among those brave souls who hunted the wumpus. But the wumpus, driven nearly to extinction, is now a protected species. But, do not fear, there is still much fun to be had involving both hunting, and wumpusses. Now you can be the wumpus, and hunt the wumpus hunters!

This game is licensed under the good old GPL v. 2.0, except for the audio files, which are licensed under the Creative Commons Sampling Plus 1.0 license.

WARNING -- this game does contain small amounts of sounds of people speaking words which some people might consider profane. If you are apt to be offended by the numbers in a .wav file when run through a D/A converter, and then the analog signal amplified then run through a loudspeaker of some kind, well, you may have a problem with my numbers then, I suppose. Thing is, it's your problem, not mine. You've been warned. And what sorts of things would you expect people trapped in a dark cave with a hungry wumpus to say?

If you don't like it, well, that's just too damned bad.

Compiling the game

Compiling is easy, after checking out from CVS as above, just type "make." You'll need the gnome libraries and header files, which you likely already have.

You may need to set a couple environment variables:

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
export LD_LIBRARY_PATH=/usr/local/lib


(I have that in my ~/.login, so I tend to forget about them.)

You'll also need libsndfile and the portaudio libraries, which there's a good chance you don't already have. These are easily compiled and installed via the traditional "./configure", "make", and (as root) "make install" commands. You need version 19 of portaudio, not 18. portaudio v. 18 is several years old, and the API has changed. I think debian may have version 18 of portaudio as the default, as I have gotten some complaints about this from debian users.

You also needs oggdec (from the vorbis-tools package) to decode the .ogg files to .wav files.

Other packages you might need:

· gtk2-devel
· pango-devel
· atk-devel
· vorbis-tools (for oggdec)

Running the game:

Type

./bethewumpus

in the directory you built it (because it expects the sound files in a "sounds" subdirectory).

Controls:

This game is best played with a controller with two joysticks, such as the Logitech Dual Action 2 Rumble. (The rumble function doesn't work with linux at the moment.) Headphones are highly recommended, and to really get anything out of the game, headphones not just recommeded, but mandatory.

If you do not have a joystick, you can play with the keyboard, arrow keys + space bar to chomp, but it sucks. Gamepads aren't too expensive, consider buying one.

· The left stick controls rotation.
· The right stick controls forward and backward motion.
· The first button makes the wumpus attack. You must be within close range of your prospective meal for this to be effective, otherwise you simply frighten the meal.

What's New in This Release:

· Ogg files are now decoded to memory rather than to disk.
· Support was added for the Xbox 360 controller rumble effect (which requires Linux kernel 2.6.26 or later).

last updated on:
August 11th, 2009, 13:49 GMT
price:
FREE!
developed by:
Stephen Cameron
license type:
GPL (GNU General Public License) 
category:
ROOT \ Games \ RPG

FREE!

In a hurry? Add it to your Download Basket!

user rating 19

UNRATED
3.7/5
 

0/5

What's New in This Release:
  • Changed makefile to use pkg-config to find portaudio libs and cflags.
read full changelog

Add your review!

SUBMIT