WebKit Exploits Repaired in Ubuntu 12.04

Canonical has fixed some important vulnerabilities

  Ubuntu 12.04 LTS desktop
On October 25, in a security notice Canonical published details about and WebKit vulnerabilities for its Ubuntu 12.04 LTS operating system.

On October 25, in a security notice Canonical published details about and WebKit vulnerabilities for its Ubuntu 12.04 LTS operating system.

According to Canonical, multiple security vulnerabilities were fixed in WebKit. A large number of security issues were discovered in the WebKit browser and JavaScript engines.

A remote attacker could have exploited a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

For a more detailed description of the security problems, you can visit Canonical's security notification.

Users can simply fix the security flaws by upgrading the operating systems to the latest libwebkitgtk package, specific to each distribution.

A normal system update, executed with the Update Manager, will implement all the necessary changes. A complete system restart is not necessary.

Comments