Ruby and RubyGems Vulnerabilities Fixed for Ubuntu 12.04 LTS

A standard system update should correct all the problems

By on September 26th, 2012 16:01 GMT

On September 25th, in a security notice Canonical published details about a few Ruby and RubyGems vulnerabilities for its Ubuntu 12.04 LTS (Precise Pangolin) operating system.

These are the three vulnerabilities found in the Ruby and RubyGems for Ubuntu 12.04 LTS: CVE-2011-1005, CVE-2012-2126, and CVE-2012-3430.

As usual, you can click on each one to see how it affects your system, or go here for in-depth descriptions to check out what other steps can be taken.

The security flaws can be fixed if you upgrade your system(s) to the latest libruby and rubygems package. To apply the update, run the Update Manager application.

In general, a standard system update will make all the necessary changes. A restart won't be necessary to implement the changes.

Comments